View unanswered posts | View active topics It is currently Sat Jul 21, 2018 12:27 am



Reply to topic  [ 2 posts ] 
PHP 7 compatibility 
Author Message
Regular pChart user
Regular pChart user

Joined: Thu Mar 31, 2011 9:19 am
Posts: 10
Post PHP 7 compatibility
Hello

I am using pChart on PHP 7, The class module
Quote:
pData.class.php
seems incompatible.
With an On Line tool (http://sandbox.onlinephpfunctions.com/) I have had this:
Quote:
Methods with the same name as their class will not be constructors in a future version of PHP; pData has a deprecated constructor
.
Thanks
Giovanni Rossati


Mon Jun 04, 2018 8:05 am
Profile
Regular pChart user
Regular pChart user

Joined: Thu Mar 31, 2011 9:19 am
Posts: 10
Post Re: PHP 7 compatibility
Hi

The problem was:
Quote:
PHP Fatal error: Uncaught Error: Call to undefined function utf8_decode
for, my be, some operation on Apache installation.
Here https://stackoverflow.com/questions/46531870/call-to-undefined-function-utf8-decode I found an answer:
Code:
sudo apt-get purge php-xml php7.0-xml
sudo apt-get install php-xml


Giovanni Rossati


Tue Jun 05, 2018 6:43 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron